Charged twice: several payments in a short period

Symptoms 

  • 2 payments in a one billing period 
  • Unexpected charge by JetBrains 
  • Auto-renewal is enabled

Environment 

  • Personal and commercial customers  
  • All Regions 
  • All products 

Cause

Backdated renewal happened because of missed payment.

Resolution 

This is expected behavior to not interrupt the continuity discount

All the payments and linked periods could be found under JetBrains Account page: 

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